This is a practical assessment and will enhance and test your practical skills related to the subject topic. You are required to set up a simple network using minimum three PCs and minimum two routers, or use simulation software to set up the same network.To complete this assessment you are expected to refer to information beyond the textbook. This assignment is open; in that, you are free to choose the devices or software you use to complete the specified tasks. Students are expected to accomplish this task by utilising the necessary commands discussed in lectures and also described in the prescribed textbook.
There are numerous websites available that discuss Linux networking. You are expected to list your sources of information for the different tasks. When completing this project, you may encounter errors or experience difficulties in getting your setup to work. If this occurs, your challenge is to analyze why they happen and report on how you solved the problems you encountered.Additional information will be provided for technology options to use in creating this lab closer to the assessment due date.
You are required to set up a network consisting of PCs, routers and servers. You need to configure routing between routers (minimum two routers required). The routers will have multiple network interfaces. The PC (client) will be connected to one of the router's interfaces and other PCs (servers) will be connected to the second router's interface.
Client <--> Router <--> Router <--> Server(s)
Setup separate server for each application/service. Each side of the router will be in its own LAN (or WAN) segment and should have a different network address, use ONLY private IP address ranges to design this network.
Perform the following activities and support your workings with screenshots [10 marks]:
1. Configure the PC, Server and Router interfaces with appropriate network addressing;
2. Configure routing (IP packet forwarding) on the routers;
3. On the client ping the client's own network interface, then the local router gateway interface, then the remote router interface, then the server;
4. Use the traceroute command from the client to the server. Include results of the traceroute in your submission.
Configuring Network Services
Using the same network topology that you have setup in Task 1, perform the following additional activities
Services
In this task assignment we are going to design a simple network consisting of 2 client personal computers (one will be statically IP address assigned-PC 0 whereas the other dynamically IP address assigned- PC 1), 2 routers (one on the client side and another on the server side, the routers will be used for IP routing), and we have three servers, that is, web server to host our web domain (www.AtherPatel.csu.edu.au), DHCP server to manage IP addresses by dynamic issuance of IP addresses and DNS server to resolve IP addresses (Meyers, 2012).
Services
The following services will be implemeted
- DNS service
- DHCP service
- WEB service
- WEB filtering service
Routing protocol used
Routing Information Protocol (RIP) is used to route traffic from client side to server and from server side to client side (Lacoste & Wallace, 2014).
Firewal implementation
Access-lists are used to implemnt firewall security measure ensuring that part of our LAN does not access web traffic
IP assignment table
Device |
Interface |
IP configuration |
Connected interface |
PC 0 |
Fe |
10.0.0.2/24 |
R1’s fa0/0 |
PC 1 |
Fe |
DHCP assigned |
R1’s f0/1 |
R1 |
Fa0/0 |
10.0.0.1/24 |
PC 0’s fe |
R1 |
Fa0/1 |
20.0.0.1/24 |
PC 1’s fe |
R1 |
S0/0/0 |
192.168.1.253/30 |
R2’s s0/0/0 |
R2 |
S0/0/0 |
192.168.1.254/30 |
R1’s s0/0/0 |
R2 |
Fa0/0 |
30.0.0.1/24 |
DHCP server fe0 |
R2 |
F0/1 |
40.0.0.1/24 |
WEB server’s fe0 |
R2 |
F1/0 |
50.0.0.1/24 |
DNS’ fe0 |
DHCP server |
Fe0 |
30.0.0.2/24 |
R2’s fa0/0 |
WEBserver |
Fe0 |
40.0.0.2/24 |
R2’s fa0/1 |
DNS server |
Fe0 |
50.0.0.2/24 |
R2’s fa1/0 |
Network topology
Configuration steps
Step 1: Router configurations
Router R1
We start by erasing any start-up memory configurations and restart it
Router>
Router>ena
Router#erase star
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
%SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Router#reloa
Proceed with reload? [confirm]
System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
Initializing memory for ECC..
C2800 processor with 524288 Kbytes of main memory
Main memory is configured to 64 bit mode with ECC enabled
Readonly ROMMON initialized
program load complete, entry point: 0x8000f000, size: 0xc940
program load complete, entry point: 0x8000f000, size: 0xc940
program load complete, entry point: 0x8000f000, size: 0x3ed1338
Self decompressing the image :
Router>
Router>ena
Router#config ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host R1
R1(config)#inter fa0/0
R1(config-if)#ip add 10.0.0.1 255.255.255.0
R1(config-if)#no shu
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#router rip
R1(config-router)#exi
R1(config)#inter f0/1
R1(config-if)#ip add 20.0.0.1 255.255.255.0
R1(config-if)#no shu
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#inter s0/0
%Invalid interface type and number
R1(config)#inter s0/0/0
R1(config-if)#ip add 192.168.1.253 255.255.255.252
R1(config-if)#no shu
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exi
R1(config)#router rip
R1(config-router)#do sho ip inter br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.0.1 YES manual up up
FastEthernet0/1 20.0.0.1 YES manual up up
Serial0/0/0 192.168.1.253 YES manual down down
Serial0/0/1 unassigned YES NVRAM administratively down down
Routing protocol used
FastEthernet1/0 unassigned YES NVRAM administratively down down
FastEthernet1/1 unassigned YES NVRAM administratively down down
Vlan1 unassigned YES NVRAM administratively down down
R1(config-router)#net 10.0.0.0
R1(config-router)#net 20.0.0.0
R1(config-router)#net 192.168.1.252
R1(config-router)#exi
R1(config)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
R1#
(Todd & William, 2014), (Velte & Velte, 2013 )
Router R2
Erasing of start-up configuration and reloading the router
Router>
Router>ena
Router#era start
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
%SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Router#reload
Proceed with reload? [confirm]
System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
Initializing memory for ECC..
C2800 processor with 524288 Kbytes of main memory
Main memory is configured to 64 bit mode with ECC enabled
Readonly ROMMON initialized
program load complete, entry point: 0x8000f000, size: 0xc940
program load complete, entry point: 0x8000f000, size: 0xc940
program load complete, entry point: 0x8000f000, size: 0x3ed1338
Self decompressing the image :
Router>
Router>ena
Router#confi ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host R2
R2(config)#inter fa 0/0
R2(config-if)#ip add 30.0.0.1 255.255.255.0
R2(config-if)#no shu
R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#inter fa0/1
R2(config-if)#ip add 40.0.0.1 255.255.255.0
R2(config-if)#no shu
R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config-if)#inter fa1/0
R2(config-if)#ip add 50.0.0.1 255.255.255.0
R2(config-if)#no shu
R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
R2(config-if)#inter s0/0/0
R2(config-if)#ip add 192.168.1.254 255.255.255.252
R2(config-if)#no shu
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#exi
R2(config)#router rip
R2(config-router)#do sho ip inter brie
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 30.0.0.1 YES manual up up
FastEthernet0/1 40.0.0.1 YES manual up up
Serial0/0/0 192.168.1.254 YES manual up up
Serial0/0/1 unassigned YES NVRAM administratively down down
FastEthernet1/0 50.0.0.1 YES manual up up
FastEthernet1/1 unassigned YES NVRAM administratively down down
Vlan1 unassigned YES NVRAM administratively down down
R2(config-router)#net 30.0.0.0
R2(config-router)#net 40.0.0.0
R2(config-router)#net 50.0.0.0
R2(config-router)#net 192.168.1.252
R2(config-router)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#copy run star
Destination filename [startup-config]?
Building configuration...
[OK]
R2#
(Tracy, 2012)
Step 2: Servers and Client IP Assignment
PC0
Ping client IP address
Packet Tracer PC Command Line 1.0
C:>ping 10.0.0.2
Pinging 10.0.0.2 with 32 bytes of data:
Firewall implementation
Reply from 10.0.0.2: bytes=32 time=3ms TTL=128
Reply from 10.0.0.2: bytes=32 time=1ms TTL=128
Reply from 10.0.0.2: bytes=32 time=1ms TTL=128
Reply from 10.0.0.2: bytes=32 time=2ms TTL=128
Ping statistics for 10.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 3ms, Average = 1ms
C:>
(Halsey & Ballew, 2017 )
Ping Client Default gateway
C:>ping 10.0.0.1
Pinging 10.0.0.1 with 32 bytes of data:
Reply from 10.0.0.1: bytes=32 time=1ms TTL=255
Reply from 10.0.0.1: bytes=32 time<1ms TTL=255
Reply from 10.0.0.1: bytes=32 time<1ms TTL=255
Reply from 10.0.0.1: bytes=32 time<1ms TTL=255
Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
C:>
From client ping remote router interface
Pinging 192.168.1.254 with 32 bytes of data:
Reply from 192.168.1.254: bytes=32 time=4ms TTL=254
Reply from 192.168.1.254: bytes=32 time=5ms TTL=254
Reply from 192.168.1.254: bytes=32 time=11ms TTL=254
Reply from 192.168.1.254: bytes=32 time=5ms TTL=254
Ping statistics for 192.168.1.254:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 4ms, Maximum = 11ms, Average = 6ms
C:>
(Ranjbar, 2014)
From client pc ping server
C:>ping 40.0.0.2
Pinging 40.0.0.2 with 32 bytes of data:
Reply from 40.0.0.2: bytes=32 time=2ms TTL=126
Reply from 40.0.0.2: bytes=32 time=3ms TTL=126
Reply from 40.0.0.2: bytes=32 time=5ms TTL=126
Reply from 40.0.0.2: bytes=32 time=5ms TTL=126
Ping statistics for 40.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 5ms, Average = 3ms
C:>
From client, tracing the server
C:>tracert 40.0.0.2
Tracing route to 40.0.0.2 over a maximum of 30 hops:
1 1 ms 0 ms 0 ms 10.0.0.1
2 3 ms 1 ms 6 ms 192.168.1.254
3 10 ms 16 ms 10 ms 40.0.0.2
Trace complete.C:>
DNS server
IP assignment
DNS Service enablement
Webserver configuration
DHCP Server Configuration
Router Command
R1>
R1>ena
R1#confi ter
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#inter f0/1
R1(config-if)#ip he
R1(config-if)#ip
R1(config-if)#ip ?
access-group Specify access control for packets
address Set the IP address of an interface
authentication authentication subcommands
flow NetFlow Related commands
hello-interval Configures IP-EIGRP hello interval
helper-address Specify a destination address for UDP broadcasts
inspect Apply inspect name
ips Create IPS rule
mtu Set IP Maximum Transmission Unit
nat NAT interface commands
IP assignment table
ospf OSPF interface commands
proxy-arp Enable proxy ARP
split-horizon Perform split horizon
summary-address Perform address summarization
virtual-reassembly Virtual Reassembly
R1(config-if)#ip helper
R1(config-if)#ip helper-address ?
A.B.C.D IP destination address
R1(config-if)#ip helper-address 30.0.0.2
R1(config-if)#
PC 1 Using DHCP to obtain IP address
Firewall filter
We are going to implement this by use of Access-list denying 20.0.0.0 LAN access of web traffic.
This is implemented at router R1
Configuration
R1(config)#acc
R1(config)#access-list 102 de
R1(config)#access-list 102 deny tcp
R1(config)#access-list 102 deny tcp ?
A.B.C.D Source address
any Any source host
host A single source host
R1(config)#access-list 102 deny tcp 20.0.0.0 0.0.0.255 ?
A.B.C.D Destination address
any Any destination host
eq Match only packets on a given port number
gt Match only packets with a greater port number
host A single destination host
lt Match only packets with a lower port number
neq Match only packets not on a given port number
range Match only packets in the range of port numbers
R1(config)#access-list 102 deny tcp 20.0.0.0 0.0.0.255 ho
R1(config)#access-list 102 deny tcp 20.0.0.0 0.0.0.255 host ?
A.B.C.D Destination address
R1(config)#access-list 102 deny tcp 20.0.0.0 0.0.0.255 host 40.0.0.2
R1(config)#access-list 102 deny tcp 20.0.0.0 0.0.0.255 host 40.0.0.2 eq
R1(config)#access-list 102 deny tcp 20.0.0.0 0.0.0.255 host 40.0.0.2 eq 80
R1(config)#acc
R1(config)#access-list 102 all
R1(config)#access-list 102 ?
deny Specify packets to reject
permit Specify packets to forward
remark Access list entry comment
R1(config)#access-list 102 pe
R1(config)#access-list 102 permit ?
ahp Authentication Header Protocol
eigrp Cisco's EIGRP routing protocol
esp Encapsulation Security Payload
gre Cisco's GRE tunneling
icmp Internet Control Message Protocol
ip Any Internet Protocol
ospf OSPF routing protocol
tcp Transmission Control Protocol
udp User Datagram Protocol
R1(config)#access-list 102 permit an
R1(config)#access-list 102 permit ?
ahp Authentication Header Protocol
eigrp Cisco's EIGRP routing protocol
esp Encapsulation Security Payload
gre Cisco's GRE tunneling
icmp Internet Control Message Protocol
ip Any Internet Protocol
ospf OSPF routing protocol
tcp Transmission Control Protocol
udp User Datagram Protocol
R1(config)#access-list 102 permit tc
R1(config)#access-list 102 permit tcp ?
A.B.C.D Source address
any Any source host
host A single source host
R1(config)#access-list 102 permit tcp any
R1(config)#access-list 102 permit tcp any ?
A.B.C.D Destination address
any Any destination host
eq Match only packets on a given port number
gt Match only packets with a greater port number
host A single destination host
lt Match only packets with a lower port number
neq Match only packets not on a given port number
range Match only packets in the range of port numbers
Network topology
R1(config)#access-list 102 permit tcp any ho
R1(config)#access-list 102 permit tcp any host 40.0.0.2 ?
dscp Match packets with given dscp value
eq Match only packets on a given port number
established established
gt Match only packets with a greater port number
lt Match only packets with a lower port number
neq Match only packets not on a given port number
precedence Match packets with given precedence value
range Match only packets in the range of port numbers
<cr>
R1(config)#access-list 102 permit tcp any host 40.0.0.2 eq 80
R1(config)#inter fa0/1
R1(config-if)#acc
R1(config-if)#ip acc
R1(config-if)#ip access-group 102 in
R1(config-if)#ip access-group 102 ?
in inbound packets
out outbound packets
R1(config-if)#ip access-group 102 in
R1(config-if)#
(Alani, 2017)
Evidence
We configured client PC 1 not to access web traffic. Let’s browse from PC 1
From above image it is evident that PC 1 cannot access web traffic as there are no results from the browser.
Username and Password configuration
Router 1 configuration
R1>ena
R1#confi ter
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#user
R1(config)#username [email protected] pass
R1(config)#username [email protected] password Ather123
R1(config)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
R1#
R1#
Router 2 configuration
R2>
R2>ena
R2#confi ter
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#user [email protected] pass Ather123
R2(config)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
copy run star
Destination filename [startup-config]?
Building configuration...
[OK]
R2#
R2#
Router Username and password
Wireless Router Configuration
R1(config)#username [email protected] pass
R1(config)#username [email protected] password Ather123
R1(config)#end
SSID and Passphrase configuration
Laptop SSID and Pass Phrase with AES encryption type
Ping tests
NB: all our ping stats will be from Laptop PC to other devices
Self ping
C:>ping 70.0.0.2
Pinging 70.0.0.2 with 32 bytes of data:
Reply from 70.0.0.2: bytes=32 time=8ms TTL=128
Reply from 70.0.0.2: bytes=32 time=2ms TTL=128
Reply from 70.0.0.2: bytes=32 time<1ms TTL=128
Reply from 70.0.0.2: bytes=32 time=3ms TTL=128
Ping statistics for 70.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 8ms, Average = 3msC:>
Ping from Laptop to PC 1
C:>ping 10.0.0.2
Reply from 10.0.0.2: bytes=32 time=16ms TTL=126
Reply from 10.0.0.2: bytes=32 time=13ms TTL=126
Reply from 10.0.0.2: bytes=32 time=10ms TTL=126
Reply from 10.0.0.2: bytes=32 time=10ms TTL=126
Ping statistics for 10.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 10ms, Maximum = 16ms, Average = 12ms
C:>
Pinging the DNS server
C:>ping 50.0.0.2
Pinging 50.0.0.2 with 32 bytes of data:
Reply from 50.0.0.2: bytes=32 time=9ms TTL=125
Reply from 50.0.0.2: bytes=32 time=6ms TTL=125
Reply from 50.0.0.2: bytes=32 time=10ms TTL=125
Reply from 50.0.0.2: bytes=32 time=7ms TTL=125
Ping statistics for 50.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 6ms, Maximum = 10ms, Average = 8ms
Pinging 40.0.0.2 with 32 bytes of data:
Reply from 40.0.0.2: bytes=32 time=16ms TTL=125
Reply from 40.0.0.2: bytes=32 time=11ms TTL=125
Reply from 40.0.0.2: bytes=32 time=10ms TTL=125
Reply from 40.0.0.2: bytes=32 time=7ms TTL=125
Ping statistics for 40.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 7ms, Maximum = 16ms, Average = 11ms
Pinging 30.0.0.2 with 32 bytes of data:
Reply from 30.0.0.2: bytes=32 time=13ms TTL=125
Reply from 30.0.0.2: bytes=32 time=13ms TTL=125
Reply from 30.0.0.2: bytes=32 time=11ms TTL=125
Reply from 30.0.0.2: bytes=32 time=11ms TTL=125
Ping statistics for 30.0.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 11ms, Maximum = 13ms, Average = 12ms
Alani, M. M. (2017). Guide to Cisco Routers Configuration: Becoming a Router Geek. Hoboken: John Wiley & Sons.
Halsey, M., & Ballew, . (2017 ). Windows Networking Troubleshooting. New York City: Apress.
Lacoste, R., & Wallace, . (2014). CCNP Routing and Switching TSHOOT 300-135 Official Cert Guide. Indianapolis: Cisco Press.
Lammle, T. (2016). CCNA Routing and Switching Complete Review Guide: Exam 100-105, Exam 200-105. Hoboken: John Wiley & Sons.
Meyers, M. ( 2012). Mike Meyers’ CompTIA Network+ Guide to Managing and Troubleshooting Networks, 3rd Edition (Exam N10-005). New York City: McGraw Hill Professional.
Pyles, J., Carrell, . L., & Tittel, . (2016). TCP/IP Networking. In Guide to TCP/IP: IPv6 and IPv4 (pp. 15-18). Boston: Cengage Learning.
Ranjbar, A. (2014). Troubleshooting and Maintaining Cisco IP Networks (TSHOOT) Foundation. Indianapolis: Cisco Press.
Todd, L., & William, T. (2014). CCNA Routing and Switching Deluxe Study Guide. Hoboken: John Wiley & Sons.
Tracy, R. (2012). CompTIA Network+ Certification Practice Exams (Exam N10-005). New York City: McGraw Hill Professional.
Velte, T., & Velte, A. (2013 ). Cisco A Beginner's Guide, Fifth Edition. New York City: McGraw Hill Professional.
To export a reference to this article please select a referencing stye below:
My Assignment Help. (2021). Configure A Simple Network With 2 Routers, 3 Servers, And An Essay.. Retrieved from https://myassignmenthelp.com/free-samples/ict41119-telecommunications-network-design/server-to-manage.html.
"Configure A Simple Network With 2 Routers, 3 Servers, And An Essay.." My Assignment Help, 2021, https://myassignmenthelp.com/free-samples/ict41119-telecommunications-network-design/server-to-manage.html.
My Assignment Help (2021) Configure A Simple Network With 2 Routers, 3 Servers, And An Essay. [Online]. Available from: https://myassignmenthelp.com/free-samples/ict41119-telecommunications-network-design/server-to-manage.html
[Accessed 12 November 2024].
My Assignment Help. 'Configure A Simple Network With 2 Routers, 3 Servers, And An Essay.' (My Assignment Help, 2021) <https://myassignmenthelp.com/free-samples/ict41119-telecommunications-network-design/server-to-manage.html> accessed 12 November 2024.
My Assignment Help. Configure A Simple Network With 2 Routers, 3 Servers, And An Essay. [Internet]. My Assignment Help. 2021 [cited 12 November 2024]. Available from: https://myassignmenthelp.com/free-samples/ict41119-telecommunications-network-design/server-to-manage.html.