Get Instant Help From 5000+ Experts For
question

Writing: Get your essay and assignment written from scratch by PhD expert

Rewriting: Paraphrase or rewrite your friend's essay with similar meaning at reduced cost

Editing:Proofread your work by experts and improve grade at Lowest cost

And Improve Your Grades
myassignmenthelp.com
loader
Phone no. Missing!

Enter phone no. to receive critical updates and urgent messages !

Attach file

Error goes here

Files Missing!

Please upload all relevant files for quick & complete assistance.

Guaranteed Higher Grade!
Free Quote
wave

You will be required to configure 802.1Q trunking connections between the switches. Each switch will be connected to another switch via two trunking connections where the second connection is used for redundancy purposes.

You will be required to configure your network Spanning Tree Protocol to PVST+ and to ensure that the distribution layer switch is the Root Bridge

Distribution Switch Configuration

Subnetting

In our subnetting area, we chose VLSM scheme. Below are the steps we took through:

  1. The subnets whose size is largest were listed at the top in a sequential order
  2. The provided network address by supervisor became our starting network address.
  3. Each VLAN that we have, we are capable of finding octet, subnet size, increment of each subnet and subnet mask
  4. In the first line of our table, we add the increment for vlan 10 to have a network address for Vlan 11.
  5. The same process continued for all the subnets
  6. We were able to get the subnet mask by minusing 1 from the network address of the next subnet.

Location

VLAN

Size

Octet

NetworkID

IP address range

Mask

English

10

2000

2048

130.30.0.0

130.30.0.1-130.30.8.254

255.255.248.0

Hindi

11

500

256

130.30.9.0

130.30.9.1-130.30.9.254

255.255.255.0

Mandarin

12

100

128

130.30.10.0

130.30.10.1-130.30.10.126

255.255.255.128

Thai

13

28

32

130.30.10.128

130.30.10.29-130.30.10.158

255.255.255.224

SWMge

14

10

16

130.30.10.160

130.30.10.161-130.30.10.176

255.255.255.240

(Lammle, 2017)

Distribution Switch Configuration

Switch>

Switch>ena

Switch#conf ter

Switch(config)#hostnam SW_Distr

SW_Distr(config)#vtp mode serv

Device mode already VTP SERVER.

SW_Distr(config)#vtp domain cisco

Changing VTP domain name from NULL to cisco

SW_Distr(config)#vtp password cisco

Setting device VLAN database password to cisco

SW_Distr(config)#inter ra f0/1-24

SW_Distr(config-if-range)#shu

SW_Distr(config-if-range)#exi

SW_Distr(config)#enab sec cisco

SW_Distr(config)#user cisco password cisco

SW_Distr(config)#banner motd #You are NOT allowed to Login into this Switch without permission#

SW_Distr(config)#line vty 0 15

SW_Distr(config-line)#passwo cisco

SW_Distr(config-line)#login

SW_Distr(config-line)#logg syn

SW_Distr(config-line)#line conso 0

SW_Distr(config-line)#password cisco

SW_Distr(config-line)#logi

SW_Distr(config-line)#logg sy

SW_Distr(config-line)#inter fa0/1

SW_Distr(config-if)#desc Router Connection

SW_Distr(config-if)#inter fa0/2

SW_Distr(config-if)#desc First Point of connection to Switch 1

SW_Distr(config-if)#inter fa0/3

SW_Distr(config-if)#descrip Second Point of connection to Switch 1

SW_Distr(config-if)#inter fa0/4

SW_Distr(config-if)#desc First Point of connection to Switch 2

SW_Distr(config-if)#inter fa0/5

SW_Distr(config-if)#descrip Second Point of connection to Switch 2

SW_Distr(config-if)#vlan 10

SW_Distr(config-vlan)#name English

SW_Distr(config-vlan)#vlan 11

SW_Distr(config-vlan)#name Hindi

SW_Distr(config-vlan)#vlan 12

SW_Distr(config-vlan)#name Mandarin

SW_Distr(config-vlan)#vlan 13

SW_Distr(config-vlan)#name Thai

SW_Distr(config-vlan)#vlan 14

SW_Distr(config-vlan)#name SwitchMge

SW_Distr(config-vlan)#inter ra fa0/1-5

SW_Distr(config-if-range)#switchpo

SW_Distr(config-if-range)#switchport maode trunk

SW_Distr(config-if-range)#switchport mode trunk

SW_Distr(config-if-range)#inter ra f0/6-24

SW_Distr(config-if-range)#shu

SW_Distr(config-if-range)#end

SW_Distr#write

SW_Distr#copy run star

Access layer switch 1

Switch(config-if-range)#

Switch(config-if-range)#

Switch(config-if-range)#exi

Switch(config)#hostname SW1_Access

SW1_Access(config)#banner mot #You are NOT allowed to Login into this Switch without permission#

SW1_Access(config)#ena secre cisco

SW1_Access(config)#usernam cisco pass cisco

SW1_Access(config)#line vty 0 15

SW1_Access(config-line)#pass cisco

SW1_Access(config-line)#line conso 0

SW1_Access(config-line)#pass cisco

SW1_Access(config-line)#login

SW1_Access(config-line)#logg sys

SW1_Access(config-line)#logg syn

SW1_Access(config-line)#vtp mode clie

Setting device to VTP CLIENT mode.

SW1_Access(config)#vtp doma cisco

Changing VTP domain name from admin to cisco

SW1_Access(config)#vtp pass cisco

Setting device VLAN database password to cisco

SW1_Access(config)#inter ra fa 0/1-4

SW1_Access(config-if-range)#swi mode trunk

SW1_Access(config-if-range)#inter range fa0/5-24

SW1_Access(config-if-range)#shu

SW1_Access(config-if-range)#end

SW1_Access#write

Building configuration...

[OK]

SW1_Access#

(Todd, 2016).

Switch 2 Configuration

Switch#conf ter

Switch(config)#host SW2_Access

SW2_Access(config)#banner motd #You are NOT allowed to Login into this Switch without permission#

SW2_Access(config)#

SW2_Access(config)#

SW2_Access(config)#vtp mode clie

Setting device to VTP CLIENT mode.

SW2_Access(config)#vtp doma cisco

Changing VTP domain name from admin to cisco

SW2_Access(config)#vtp pass cisco

Setting device VLAN database password to cisco

SW2_Access(config)#inter ra fa 0/1-4

SW2_Access(config-if-range)#swi mode tr

SW2_Access(config-if-range)#inter fa0/9-24

SW2_Access(config-if-range)#inter ra fa0/9-24

SW2_Access(config-if-range)#shu

SW2_Access(config-if-range)#inter fa0/3

SW2_Access(config-if)#desc First Point of Connection to Distribution switch

SW2_Access(config-if)#inter fa0/4

SW2_Access(config-if)#desc Second Point of Connection to Distribution switch

SW2_Access(config-if)#inter fa 0/1

SW2_Access(config-if)#desc First Point of Connection to SW1 accesss switch

SW2_Access(config-if)#inter fa 0/2

SW2_Access(config-if)#desc second Point of Connection to SW1 accesss switch

SW2_Access(config-if)#inter fa 0/9

SW2_Access(config-if)#desc Connection to LAN 14 Devices

SW2_Access(config-if)#inter fa 0/8

SW2_Access(config-if)#desc Connection to LAN 13 Devices

Access layer switch 1 Configuration

SW2_Access(config-if)#inter fa 0/7

SW2_Access(config-if)#desc Connection to LAN 12 Devices

SW2_Access(config-if)#inter fa 0/6

SW2_Access(config-if)#desc Connection to LAN 11 Devices

SW2_Access(config-if)#inter fa 0/5

SW2_Access(config-if)#desc Connection to LAN 10 Devices

SW2_Access(config)#inter fa0/9

SW2_Access(config-if)#swi

SW2_Access(config-if)#switchport acc

SW2_Access(config-if)#switchport access vla 14

SW2_Access(config-if)#inter fa0/8

SW2_Access(config-if)#switchport access vla 13

SW2_Access(config-if)#inter fa0/7

SW2_Access(config-if)#switchport access vla 12

SW2_Access(config-if)#inter fa0/6

SW2_Access(config-if)#switchport access vla 11

SW2_Access(config-if)#inter fa0/5

SW2_Access(config-if)#switchport access vla 10

SW2_Access(config-if)#exit

SW_Distr(config)#spanning-tree mode pvst

SW_Distr(config)#sp

SW_Distr(config)#spanning-tree vlan 10 root primary

SW_Distr(config)#

SW2_Access(config-if)#end

SW2_Access# 

SW2_Access#write

SW2_Access#

(Mohammed, 2017), (Teare, et al., 2015).

Router configuration

Router>

Router>ena

Router#conf ter

Router(config)#hostname RouterN

RouterN(config)#inter g0/0

RouterN(config-if)#no shu 

RouterN(config-if)# 

RouterN(config-if)#no ip add

RouterN(config-if)#desc Direct connection to Distribution Switch Interface

RouterN(config-if)#intr g0/0.10 

RouterN(config-if)#inter g0/0.10

RouterN(config-subif)#

RouterN(config-subif)#enca

RouterN(config-subif)#encapsulation dot

RouterN(config-subif)#encapsulation dot1Q 10

RouterN(config-subif)#ip addr 130.30.0.1 255.255.248.0

RouterN(config-subif)#inter g0/0.11

RouterN(config-subif)#

RouterN(config-subif)#encapsulation dot1Q 11

RouterN(config-subif)#ip addr 130.30.9.1 255.255.255.0

RouterN(config-subif)#inter g0/0.12

RouterN(config-subif)#

RouterN(config-subif)#encapsulation dot1Q 12

RouterN(config-subif)#ip addr 130.30.10.1 255.255.255.128

RouterN(config-subif)#inter g0/0.13

RouterN(config-subif)#

RouterN(config-subif)#encapsulation dot1Q 13

RouterN(config-subif)#ip addr 130.30.10.129 255.255.255.224

RouterN(config-subif)#inter g0/0.14

RouterN(config-subif)#

RouterN(config-subif)#encapsulation dot1Q 14

RouterN(config-subif)#ip addr 130.30.10.161 255.255.255.240

RouterN(config-subif)#exi

RouterN(config)#ip dhcp pool English

RouterN(dhcp-config)#network 130.30.0.0 255.255.248.0

RouterN(dhcp-config)#defau

RouterN(dhcp-config)#default-router 130.30.0.1

RouterN(dhcp-config)#ip dhcp pool Hindi

RouterN(dhcp-config)#network 130.30.9.1 255.255.255.0

RouterN(dhcp-config)#no network 130.30.9.1 255.255.255.0

RouterN(dhcp-config)#network 130.30.9.0 255.255.255.0

RouterN(dhcp-config)#default-router 130.30.9.1

RouterN(dhcp-config)#ip dhcp pool Mandid

RouterN(dhcp-config)#network 130.30.10.0 255.255.255.128

RouterN(dhcp-config)#default-router 130.30.10.1

RouterN(dhcp-config)#ip dhcp pool Thai

RouterN(dhcp-config)#network 130.30.10.128 255.255.255.224

RouterN(dhcp-config)#default-router 130.30.10.129

RouterN(dhcp-config)#ip dhcp pool SWMge

RouterN(dhcp-config)#network 130.30.10.160 255.255.255.240

RouterN(dhcp-config)#default-router 130.30.10.161

RouterN(dhcp-config)#end

RouterN# 

RouterN#copy run start

RouterN# 

Etherchannel configuration 

SW_Distr(config)#inter ra f0/2-3

SW_Distr(config-if-range)#channel-gro 3 mo acti

SW_Distr(config-if-range)#exi

SW_Distr(config)#interface port-chan 3

SW_Distr(config-if)#switch tru allowed vla al

SW_Distr(config-if)#end

SW_Distr#

copy run star

SW1_Access#

SW_Distr#

Device configuration summary

Switch

Code

Explanation

Switch>ena

We enter into enable mode

Switch#conf ter

We enter into global configuration mode

hostnam SW_Distr

Rename the switch as SW_Distr

vtp mode serv

Enable the switch as the VTP server

vtp domain cisco

We provide the vtp domain name

vtp password cisco

We create password for the VTP mode

inter ra f0/1-24

We enter interface mode

enab sec cisco

Created enable password

user cisco password cisco

Configured telnet parameters

banner motd #You are NOT allowed to Login into this Switch without permission#

Created message of the day

line vty 0 15

Entered into terminal mode

passwo cisco

Provided password for terminal session

desc Router Connection

Provides interface description

vlan 10

Created Vlan 10

name English

Provided name to vlan 10

switchport mode trunk

Configured the concerned ports to work in trunk mode

channel-gro 3 mo acti

Enabled etherchannel

interface port-chan 3

Entered into port channelling interface

switch tru allowed vla al

Allowed all vlans to use the port chanel

spanning-tree mode pvst

Configured per-vlan spanning-tree protocol

spanning-tree vlan 10 root primary

Forced distributon switch to be root-bridge

Router

Command

Explanation

hostname RouterN

Provided name to the router

inter g0/0

Entered into interface mode

no shu

Activated the interface

no ip add

Removed any IP address from the interface

desc Direct connection to Distribution Switch Interface

Provided the interface description

inter g0/0.10

Created a virtual interface

encapsulation dot1Q 10

Activated dot1Q trunking technology

ip addr 130.30.0.1 255.255.248.0

Specified network address for the interface

ip dhcp pool English

Created a DHCP pool to manage IP addressing dynamically

network 130.30.0.0 255.255.248.0

Specified the network address for the dhcp pool

copy run start

Saved running configuration to flash memory

Spanning tree implementation: I deployed pervlan spanning tree protocol active due to its ability to enhance modularity activities at the Vlan level.

Port security: port security violation shutdown is deployed. Just in case there is a violation of the set parameter, the switch port goes off. No any other activity will take place until the port is actively turned on by the administrator.

Switch allocation: in our design, some interfaces were allocated to trunk mode. Trunk mode allocation enables this ports to carry information for more than one VLAN. On other hand, some ports were allocated to access mode. These are the ports that are directly connected to end nodes as they carry traffic for only one vlan.

Redundancy planning: for the purposes of minimal downtime, we created 2 trunk links between two switches, just in case one fails, another link will pick. Ether-channel technology is also used to improve on the speed of traffic. Here more than one trunk link are bundled together and the bundle appears to be as a single link. 

 Overall network functionality: we use ping tool. 

Redundant link: we disable one link and test the functionality

SW2_Access#conf ter

SW2_Access(config)#inter ra f0/1

SW2_Access(config-if-range)#shut 

Here we disabled one link of the network and tested the overall working, everything is working good.

Spanning tree test  

Ether-channel test

References

Eric, M., 2012. Network Security A Beginner's Guide 3/E. Pennsylvania: McGraw Hill Professional.

Lammle, T., 2017. Subnetting. Hoboken: Wiley.

Mohammed, A., 2017. Guide to Cisco Routers Configuration: Becoming a Router Geek. New York City: Springer.

Teare, D., Vachon, ‎. & Graziani, ‎., 2015. CCNP Routing and Switching Foundation Learning Guide Library. Indianapolis: Cisco Press.

Thanasis, K., ‎Michael, Z. & ‎Maximilian, O., 2012. Testbeds and Research Infrastructure: Development of Networks and Comminities. New York City: Springer.

Todd, L., 2016. CCNA Routing and Switching Complete Review Guide: Exam 100-105. Hoboken: John Wiley & Sons.

Cite This Work

To export a reference to this article please select a referencing stye below:

My Assignment Help. (2021). Configuring Subnetting Using VLSM Scheme. Retrieved from https://myassignmenthelp.com/free-samples/tne60006-networks-and-switching/subnet-mask.html.

"Configuring Subnetting Using VLSM Scheme." My Assignment Help, 2021, https://myassignmenthelp.com/free-samples/tne60006-networks-and-switching/subnet-mask.html.

My Assignment Help (2021) Configuring Subnetting Using VLSM Scheme [Online]. Available from: https://myassignmenthelp.com/free-samples/tne60006-networks-and-switching/subnet-mask.html
[Accessed 19 June 2024].

My Assignment Help. 'Configuring Subnetting Using VLSM Scheme' (My Assignment Help, 2021) <https://myassignmenthelp.com/free-samples/tne60006-networks-and-switching/subnet-mask.html> accessed 19 June 2024.

My Assignment Help. Configuring Subnetting Using VLSM Scheme [Internet]. My Assignment Help. 2021 [cited 19 June 2024]. Available from: https://myassignmenthelp.com/free-samples/tne60006-networks-and-switching/subnet-mask.html.

Get instant help from 5000+ experts for
question

Writing: Get your essay and assignment written from scratch by PhD expert

Rewriting: Paraphrase or rewrite your friend's essay with similar meaning at reduced cost

Editing: Proofread your work by experts and improve grade at Lowest cost

loader
250 words
Phone no. Missing!

Enter phone no. to receive critical updates and urgent messages !

Attach file

Error goes here

Files Missing!

Please upload all relevant files for quick & complete assistance.

Plagiarism checker
Verify originality of an essay
essay
Generate unique essays in a jiffy
Plagiarism checker
Cite sources with ease
support
Whatsapp
callback
sales
sales chat
Whatsapp
callback
sales chat
close